Your server is running PHP version 5.0.5 but WordPress 4.0 requires at least 5.2.4.